首页 技术文章 后端开发 如何解决strict standards php报错问题
正文 评论

如何解决strict standards php报错问题

strict standards php报错的解决办法:1、在父类之后定义继承类;2、在“setup-config.php”文件中添加“error_reporting( ~(E_STRICT | E_NOTICE));”。

如何解决strict standards php报错问题

本文操作环境:Windows7系统,PHP5.3.3版,Dell G3电脑。

如何解决strict standards php报错问题?

PHP中Strict Standards错误解决方法

在PHP5.3.3 中安装wordpress 3.0.1 ,在安装时出现错误:

Strict Standards: PHP Strict Standards: Declaration of Walker.....的解决办法:

出现错误提示:

Strict Standards: PHP Strict Standards: Declaration of Walker_Page::start_lvl() should be compatible with that of Walker::start_lvl() in E:\\Webroot\\wordpress\\wp-includes\\classes.php on line 1199 PHP Strict Standards: Declaration of Walker_Page::end_lvl() should be compatible with that of Walker::end_lvl() in E:\\Webroot\\wordpress\\wp-includes\\classes.php on line 1199 PHP Strict ........

错误原因:

这是由于 php 5.3版本后。要求继承类必须在父类之后定义。否则就会出现Strict Standards: PHP Strict Standards: Declaration of .... should be compatible with that of .... 的错误提示。也就是说必须父类在前,继承类在后。

错误参考页面。

bugs点php点net/bug.php?id=46851 (不能发表带链接的网址) 上面清楚地解释了出现此类错误的具体原因。

解决办法:

在wordpress3.0.1 文件中,找到 wp-admin\\setup-config.php 文件。

在require_once('../wp-includes/compat.php'); 上面添加一句:

error_reporting( ~(E_STRICT | E_NOTICE));

问题解决。

这句话的意思是错误报告设置:显示所有错误,但是除了严格错检查或者错误报告。也就是说PHP5.3.3 不执行严格错误检查。也不显示错误提示。跳过严格错误检查。

推荐学习:《PHP视频教程》

以上就是如何解决strict standards php报错问题的详细内容,更多请关注主题君其它相关文章!

-=||=-收藏赞 (0)
更多主题
单栏极简文艺WordPress博客主题:Diaspora主题
¥ 0 关注:20,335
详情
简约黑白WordPress个人博客主题:Personal主题
¥ 0 关注:20,182
详情
v1.0.0
小程序收录免费WordPress主题:XCX主题
¥ 0 关注:19,956
详情
v1.0.0
一款简约单栏的免费WordPress博客主题:itheme主题
¥ 0 关注:18,219
详情
功能丰富切轻量的WordPress虚拟资源主题:Rizhuti主题
¥ 599 关注:18,174
详情
大气优雅免费WordPress博客主题:HONEY主题
¥ 0 关注:15,001
详情
回复
暂无评论

不要再留垃圾评论了,主题君整理资源不容易,留几句鼓励的话吧。