首页 技术文章 后端开发 怎么更改php.ini文件支持pdo抽象层
正文 评论

怎么更改php.ini文件支持pdo抽象层

方法:1、打开配置文件“php.ini”;2、查找“pdo_firebird”、“pdo_oci”、“pdo_odbc”、“pdo_pgsql”等PDO相关的配置信息,将配置项前面的分号“;”去除;3、重启Apache服务器即可。

怎么更改php.ini文件支持pdo抽象层

本教程操作环境:windows7系统、PHP7.1版、DELL G3电脑

PDO 是什么

PDO 是 PHP Date Object(PHP 数据对象)的简称,它是 PHP 为访问数据库定义的一个轻量级的、一致性的接口,它提供了一个数据访问抽象层,这样无论你使用什么数据库,都可以通过同一函数执行查询和获取数据,大大简化了数据库的操作,并能够屏蔽不同数据库之间的差异。

PDO 是与 PHP5.1 版本一起发行的,使用 PDO 可以很方便地进行跨数据库程序的开发,以及不同数据库间的移植,目前 PDO 支持的数据库包括 Firebird、FreeTDS、Interbase、MySQL、SQL Server、ODBC、Oracle、Postgre SQL、SQLite 和 Sybase 等。

有了 PDO 就不必再使用 mysqli_* 的一系列函数了,只需要使用 PDO 中的方法就可以对数据库进行操作。

开启 PDO

PDO 是与 PHP5.1 一起发行的,默认包含在 PHP5.1 中。由于 PDO 需要 PHP5 核心面向对象特性的支持,因此其无法在 PHP5.0 之前的版本中使用。

默认情况下,PDO 在 PHP 中为开启状态,但是要启用对某个数据库驱动程序的支持,仍需要进行相应的配置操作。

以 Windows 系统下为例,在配置文件 php.ini 中有关 PDO 相关的配置信息如下所示:

;extension=pdo_firebird
;extension=php_pdo_mysql.dll
;extension=pdo_oci
;extension=pdo_odbc
;extension=pdo_pgsql
;extension=pdo_sqlite

提示:开启相应的配置只需要去除配置项前面的分号;,然后重启 Apache 服务器即可。

验证相关的配置是否开启成功,只需要执行 phpinfo() 函数就行,在输出的页面中搜索配置的名称,如果存在则说明开启成功,如下图所示:

怎么更改php.ini文件支持pdo抽象层

推荐学习:《PHP视频教程》

以上就是怎么更改php.ini文件支持pdo抽象层的详细内容,更多请关注主题君其它相关文章!

-=||=-收藏赞 (0)
更多主题
单栏极简文艺WordPress博客主题:Diaspora主题
¥ 0 关注:20,013
详情
简约黑白WordPress个人博客主题:Personal主题
¥ 0 关注:19,974
详情
v1.0.0
小程序收录免费WordPress主题:XCX主题
¥ 0 关注:19,582
详情
v1.0.0
一款简约单栏的免费WordPress博客主题:itheme主题
¥ 0 关注:18,105
详情
功能丰富切轻量的WordPress虚拟资源主题:Rizhuti主题
¥ 599 关注:17,994
详情
大气优雅免费WordPress博客主题:HONEY主题
¥ 0 关注:14,845
详情
回复
暂无评论

不要再留垃圾评论了,主题君整理资源不容易,留几句鼓励的话吧。